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About This White Paper
This Intermedia white paper examines key factors to consider when preparing, planning and 
selecting a provider for large-scale migrations. It provides insights into:

• Managing risks associated with large-scale migrations and strategies to avoid common pitfalls

• Provider capability requirements and key metrics

• Methodology for large-scale migrations, including technology, processes and roles in each stage

In addition, it offers screening questions you can ask to get insight into your provider’s capabilities, 
process, timing and support.
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I. Executive Summary
Many business and IT leaders understand the value of upgrading to a newer version of Microsoft 
Exchange. However, there are a number of reasons why organizations decide to minimize risk by 
delaying migration. These include:

• Previous experience with failed or derailed migrations

• Large-scale migrations occur only every few years, so internal resources 
can lack current experience with the latest versions and methods 

• Internal resources need to keep primary focus on activities related to the core business

• A “wait and see approach” to evaluate how newer versions perform and deliver on promises

• Anecdotal performance reports create concern that newer 
versions are not relevant to a unique environment

• Migration time commitments can overextend even the most capable IT team

However, there’s a risk inherent in avoiding risk: the status quo becomes a competitive weakness. 
That happens because outdated versions will eventually compromise IT’s ability to deliver value and 
reliability back to the business. 

This white paper explores the specific elements necessary for a successful Exchange migration. In 
general, success can be assured when the team performing the migration is 1) well-prepared to 
initiate the process, 2) in possession of the technical capabilities to execute the migration, and 3) 
committed to adhering to a proven methodology that is designed to minimize the demands on the 
organization’s IT staff.

white pAper:

A Systematic Approach for Large-Scale Migrations  



5

II. How Intermedia Approaches Migrations
Intermedia has migrated over 450,000 mailboxes in the last three years. We’ve done this for airlines, 
financial services providers, law firms, telecoms and nearly every other kind of company in between. 
Our standardized methodology, extensive experience and proprietary tools create a structure for 
success, from initial consultation through successful implementation. 

Intermedia’s experts—known as the Cloud Concierge™ team—are dedicated to making large-scale 
migrations technically sound and seamless, with best practices that have been field-tested many 
times over. Our experts understand that technical expertise, close collaboration and preparedness 
are essential for reducing the risks and stress associated with large-scale migrations. 

Intermedia uses a suite of proprietary tools during the migration process. These include:

• Outlook Backup imports and exports mail data directly from Intermedia’s HostPilot™ 
Control Panel. HostPilot is our proprietary control panel which gives account 
administrators the control they are accustomed to seeing with an on-premise solution.

• Our Onboarding Tool securely pulls mail data remotely from an in-house 
Exchange environment. It also rapidly creates Exchange accounts, including 
mailboxes, contacts, distribution groups, and email addresses.

• Mail Flow Redirection manages DNS propagation for a smooth 
transition of mailflow to Intermedia servers.

These tools ensure a consistent process that adheres to best practices, enables Intermedia to 
intercept and remediate issues, and streamlines migrations to minimize disruption.

Migration Metrics 
Intermedia has a consistent track record of delivering successful large-scale migrations to strategic 
partners.

• In 2011, for a national telecommunications provider, Intermedia migrated over 5,000 
Exchange mailboxes associated with more than 300 accounts.  The migration from 
a competitive Exchange hosting provider, which was performed over the span of 
2 months, had no customer downtime and resulted in no customer churn.

• In the final two months of 2012, for a regional telecommunications provider, Intermedia 
migrated more than 1,800 mailboxes.  The migration from an in-house Exchange installation 
resulted in no churn and no customer downtime. The regional telecommunications 
provider used our migration tools to perform the migration, which was the first 
time that our Cloud Concierge™ Onboarding Tool was used on a large scale.
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A few other key numbers:

• Migrations during 2013:

• Mailboxes Over 175,000

• Accounts 8,729

• Largest migration to date:

• EasyJet  2700 Exchange + 7600 POP

• VAMortgage 1329 from Google

• Compare Intermedia to other hosted Exchange providers

We performed a review of the migration services offered by a number of hosted Exchange providers. 
As you can see from the table below, on a scale from 1-5, Intermedia scored the highest.

Intermedia Office 365
Google 
Apps

Rackspace Apptix Quest
Migration 

Wiz

ToTal Score 5.0 3.5 3.2 3.3 2.7 2.3 2.8

MigraTion coMponenTS/
Score

5 4 3 3 2 1 1

gal exporT Yes Yes Yes No No No No

roH exporT Yes Yes Yes Yes Yes/Cost Yes Yes

DnS Yes Yes Yes Yes Yes No No

coexiSTence Poor Poor No Poor Poor No No

DifferenTial exporT Yes Yes No No Yes Yes Yes

enD USer profile Yes No No Yes Yes No No

pUblic folDerS Yes No No No No No No
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More about Intermedia 
Intermedia is the premier provider of cloud services to small and medium-sized businesses and the 
world’s largest third-party provider of hosted Microsoft Exchange. Intermedia’s Office in the Cloud™ 
suite offers essential business services—including hosted Exchange, Hosted PBX and SecuriSync 
file sync and share—that enable customers to communicate, collaborate and manage content. All 
of these services are managed using Intermedia’s powerful HostPilot™ control panel. Intermedia’s 
services are delivered from top-tier datacenters, protected by enterprise-grade security, and 
supported by its premium 24/7 customer care. Fully integrated and designed for mobility, these 
services provide a worry-free experience that keeps customers focused on doing business. 

Today, Intermedia powers over 700,000 premium hosted Exchange mailboxes—far more than any 
other provider worldwide. 

Key facts about Intermedia: 

• 10% share of U.S. market with over 700,000 mailboxes under management

• Large and proven deployments of Lync, SharePoint, Hosted PBX, Cloud Server and more

• 13k+ partners, including Fortune 100 companies such as Dell, Ingram Micro, Tech Data and more

• Proven telco partnering success, including sales enablement, 
migration of existing and new customers

• Over 120,000 small and medium-size businesses use Intermedia 
services directly and through our partners 
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III. Managing Migration Risk 
Many of the most common problems created during a large-scale migration can be avoided or 
mitigated. The following list presents a number of common issues and the strategies Intermedia 
suggests for preventing them.

Issues with Copiers and Scanners

Many clients have copiers, scanners, automated alert systems and other devices that need to send 
mail to external recipients, but do not support secure connections or username and password 
authentication. To migrate them, Intermedia uses unauthenticated relays, but requires the public IP 
address of the sending device. 

Third party integration issues

Some clients have integrated third-party systems. Examples include Cisco Unity and CRM software 
as well as Unified Messaging or VOIP systems. To avoid issues, you should discuss any systems that 
require mailbox access rights or other special integration with Exchange.  

DNS propagation issues

DNS records will need time to propagate before cutover becomes a possibility. A premature cutover 
could result in mail delivery issues or Outlook profiles using an obsolete Autodiscover record. If 
you are using—and you will continue to use—a service such as Postini or McAfee SaaS, you should 
change the MX records to which this appliance points.  This should instantly switch the delivery 
destination to Intermedia.   

MX records issues

It is important to make sure your provider compensates for time that the DNS propagation of MX 
records takes. Intermedia does this by setting our Mail Flow to redirect any incoming mail we receive 
to the source server for a given domain. This will route mail sent to your email address to your 
current mail server to simplify the migration process and limit the impact of changing MX records. 
When cutover time comes, you only need to turn off Mail Flow Redirection and all mail will be 
delivered to your new mailbox in a matter of minutes.

Mail Flow Redirection will only redirect email for addresses that exist on your Intermedia account, 
including distribution lists and mail-enabled public folders. If you have changed the naming 
convention for your email addresses, you must add the old address as an alias for the user. If there is 
an address not being migrated over to Intermedia, this address will no longer receive mail once Mail 
Flow Redirection is in place.

Cutover issues: High Bandwidth Use at Cutover

We recommend users create their new Outlook profiles ahead of cutover, but after bulk data pull. 
This ensures that they have time to build their .OST cache files before cutover. The delta data pull can 
use up a lot of bandwidth—and in a migration from an in-house Exchange server, building local cache 
files on top of a data pull can use up enough bandwidth to negatively impact users.
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Cutover issues: Autodiscover

When migrating from in-house Exchange 2007 and above, Autodiscover records and SCP objects in 
ActiveDirectory in legacy Exchange 2007 and 2010 environments must be altered during the cutover. 
Intermedia provides its customers with a guide on how to perform these changes. 

Cutover issues: BlackBerry Reactivation

BlackBerries that will be using a new BES service must be wiped if they are using a legacy BES 
Server. This removes old policies. While security wipes on modern Blackberry devices should not 
remove personal information, you may want to use the BlackBerry desktop manager to perform a 
backup beforehand. 

Once the device is wiped, users can perform enterprise activation using the settings and password 
from the HostPilot control panel at the point of cutover. Alternatively, Blackberry users could be 
moved to an ActiveSync device as a part of the migration avoiding this altogether.
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IV. Key Questions for a Worry-Free 
Migration
How do you know if you’ve selected the right Exchange migration team? Intermedia recommends 
to its customer and prospects that they ask the following questions to any provider that they are 
considering—including Intermedia. 

Provider Questions

• How much do you charge for migration?

• How much experience do you have with migrations?

• What kind of guarantees do you provide?

• Will you customize the migration to my needs?

• What are your common best practices?

Process Questions

• What is your migration process?

• How will my historical data be transferred?

• How will I recreate all of the objects and configuration (e.g., 
mailboxes, contacts, distribution groups, etc.)?

• What tools do you use to facilitate migration?

• How will you minimize impact to end-users?

• Do you help with end user configuration?

• Do you help with end-user communication?

• How do you handle slow transfer rates?

• What is your solution to network saturation?

Timing Questions

• How long will the migration take?

• How much time and effort should I budget for this process?

• How much control do I have over the timing of the migration?

• How do you handle DNS propagation issues to minimize downtime?

Support Questions

• Do you provide a dedicated migration coordinator?

• Whom do I call when there are issues?

• What kind of response time can I expect?

• Do you offer 24/7 migration support?

• What is my escalation path?

• Is your overnight support staff fully qualified and empowered to resolve issues?
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V. Intermedia’s Methodology for Large-Scale 
Migrations
A successful large-scale migration requires a systematic approach and deep systems knowledge for 
consultation, planning and implementation. It should be viewed as a process, instead of an isolated 
event. 

It’s critical to coordinate resources across your organization in order to minimize the impact to end-
users. Intermedia’s phased approach does so within a structure with three benefits: it mitigates risk, 
it makes allowances for the necessary flexibility to address challenges unique to an organization, and 
it delivers reliability during and after the process.

Phase 1: Preparation Phase 2: Data Migration Phase 3: Cutover

Plan end-user communication needs 
and schedule

Onboarding perform initial data 
transfer; approximately 1-4 weeks 
before cutover

Customer change mail routing 
through Mail Filter Service; OR, 
Onboarding changes Mail Filter 
redirection

Confirm if/how many SMTP-enabled 
devices (scanner, website script) need 
to send email

Onboarding provide mailbox item 
count report to Customer

Customer create/change CNAME 
Autodiscover DNS record

Custom provide IPs of SMTP-enabled 
devices to onboarding

Customer QA Customer create SPF record

Confirm MAPI connection configured 
from new Exchange 2010 server to 
in-house Exchange server

Initial bulk copy of Public Folder data
Onboarding perform differential 
mailbox data copy

Provide MAPI server connection 
settings; test and verify connectivity 
from new Exchange server to old

Schedule final cutover date and time
Customer perform differential Public 
Folder data copy

Lower TTLs on current MX records 
for all domains (3600 seconds 
recommended)

All users on Outlook 2007/2010/2013, 
Outlook 2011 for Mac

Customer QA

Create exmerge account; provide 
username/password to Onboarding

Set Mail Flow Redirection Path; 
update public DNS MX records (if 
needed)

Open Outlook profiles; begin 
download of .ost cache file

Onboarding performs GAL Export 
(obtains MBX, aliases, DL members, 
contacts)

Reconfigure SMTP devices

Customer QAs exported data Reconfigure Active Sync device

Create MBs, DLs, Contacts on 
onboarding account

Update public Autodiscover records, 
correct SCP object

Pre-configure new workstation 
profiles
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During each phase of the migration, Intermedia recommends that you communicate with end-
users regarding any actions required. For example, users should receive an initial notification of the 
day, month, date and time/time zone for their specific email migration. On the actual cutover date, 
users should receive another notification with specific tasks to complete that day, and information 
regarding their profile, passwords, preparing Outlook for first use, and resources to contact for 
support. For wording examples, see Appendix A: Sample Email Notifications   

Phase 1: Preparation

In Phase 1, Intermedia will work closely with partners to lay a solid foundation by gathering key 
information and conducting preliminary testing. During this phase, Intermedia and the partner 
identify the resources to engage and their contact information, and the partner provides server 
connection settings for FQDN, proxy, and other relevant information.

Due diligence will be conducted by Intermedia, including determining whether the account is created 
in a datacenter that is appropriate for their location; the details of the current email environment; 
and anticipating factors like Exchange Autodiscover issues. In this stage, the team will identify which 
Public Folders are being migrated, and whether the use of Blackberry Enterprise is a factor for those 
on Exchange 2013. They will also evaluate whether the client has copiers or applications that will 
send emails, and will collect server, user and connection information. Similarly, the partner should 
troubleshoot connection issues in conjunction with Intermedia’s engineers, and repair or reconfigure 
as needed. The partner will also create an ExMerge user or provide individual usernames and 
passwords. We also need access to a user with publishing editor or owner rights to all public folders 
and subfolders you would have us migrate.

In this phase, Intermedia will also explain potential issues related to good mailbox hygiene like 
mailbox size, item count per folder, individual mail item size and other characteristics, and explain 
how to remediate these issues to minimize slow-down and to avoid problems with Export Content 
operations. In tandem, the partner conducts discovery of all systems that are integrated with the 
email system that are not related to Intermedia’s services, like faxes, copiers, newsletter software, 
crm, or um. 

Next, Intermedia will set expectations for Outlook Profile settings that may not carry over to the 
new profile, including Rules, Categories, auto-complete cache and signatures. Some of these can 
be manually imported by end users. Intermedia will also explain the process for .ost caching and 
the potential effect on customer network and Outlook speed while it is in progress. Remediation can 
include staging the creation of Outlook profiles and .ost downloads, while remaining users utilize 
OWA. The partner confirms access to third-party services, including Domain Registrar and DNS host, 
and determines if an Outlook Anywhere/RPC Over HTTP(S) is enabled.

Intermedia can then move on to testing the connection. During this step, access is tested to all 
mailboxes from Outlook, Onboarding Tool, or our internal tools. Any issues during this step are 
addressed with the client. For Exchange, we will review issues with responding to local messages 
sent before the migration and methods of user creation. These methods may include GAL export, 
CSVDE or DirectoryLink, and random passwords are assigned for increased security. Mailboxes, 
contacts and distribution lists to be created are also reviewed, prior to creating objects.

The last step in this phase is creating objects by importing the AD object list to Intermedia’s server. 
The partner reviews the lists of contacts, distribution lists and users before and after creation, and 
performs a thorough quality assurance check to verify that all needed objects exist on Intermedia’s 
server. Once Intermedia enables Mail Flow Redirection (if a third party filtering service is not being 
used), the partner changes the MX record.
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Phase 2: Data Transfer

During Phase 2, Intermedia will complete the initial data copy. This includes setting expectations 
for the data migration, and explaining the differences associated with IMAP data migrations. It is 
important to consider the effect on the client’s network and adjust tasks as appropriate, and to 
monitor the data migration while keeping the client informed. As this step is underway, the partner 
must consider available network bandwidth and, in conjunction with Intermedia’s engineers, 
determine the appropriate number of connections.

Next, Intermedia completes the initial public folder copy. Once the mail and public folder copy is 
complete, a cutover date, time and time zone can be scheduled. The partner provides added control 
and assurance by performing a thorough quality assurance check of all mailbox and public folder 
content.

Finally, Intermedia adds the IP address to the unauthenticated relay server, if needed. The partner is 
responsible for supplying the external IP address for the unauthenticated relay server to Intermedia. 

Phase 3: Cutover

At the scheduled time, Intermedia will cutover and turn off the Mail Flow Redirection, either 
automatically or after a verbal confirmation with the customer. The partner manages profile 
switching as well as modification and deployment.

Intermedia creates a differential data copy, while the partner emails the client to setup Outlook 
profiles using either Outlook Profile Helper, Single Sign-On or Autodiscover. An external Autodiscover 
record is created and all internal Autodiscover entries are deleted. Mobile device setup is completed, 
followed by the reconfiguration of all SMTP-enabled devices to use the hostname of the provider’s 
unauthenticated relay server. 

VI. Summary
The acts of preparing, planning and selecting a provider for a large-scale migration may seem as 
daunting as the migration itself. However, you can alleviate most concerns by understanding the 
capabilities required and methodology the provider will apply. 

In addition, many of the risks associated with a large-scale migration can be mitigated simply by 
asking the right questions and entrusting the process to a provider with proven experience. 

Migrations are necessary for keeping current and staying competitive. To lay the foundation for a 
successful migration, you need confidence in the process, timing and support that will be provided 
during every phase. This, then, will ensure a well-executed migration—and, in turn, ensure that your 
users benefit from the evolutions in technology that deliver ever-increasing value. 

For more information about how Intermedia can help with your migration challenges, contact your 
Intermedia representative at 800.379.7729.
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Appendix A: Sample Email Notifications for 
end-users 
Email 1: Notice of Email Profile Conversion Date & 
Procedure
$USERNAME | Email Migration Documentation

YOUR EMAIL PROFILE IS SCHEDULED TO CONVERT ON

[DAY OF WEEK, MONTH, DAY OF MONTH, 2013 @ TIME + TIME ZONE]

Do NOT use the old email system after the time specified above.

This includes the current OUTLOOK profile, WIRELESS profile and $USERNAME OWA account.

Overview of the Outlook Profile Conversion
$USERNAME is undergoing an email platform migration. This affects all Exchange mailboxes, 
archives, wireless devices and applications. The detailed steps for the conversion process are 
outlined below under Steps for converting your Outlook profile.

What does this mean for me?

This means that as of the date specified above, you will no longer be using your old $USERNAME 
Outlook profile and will be using the new Outlook Exchange profile. This also means that you will no 
longer be using the old Exchange ActiveSync profile on your wireless phone (if applicable). 

Who do I contact if I have an issue during my conversion?

If you are having issues with your conversion during the cutover window, please contact your local 
administrators.

When is my conversion scheduled? MONTH, DAY OF MONTH, 2013 @ TIME (+ZONE)

What information will be migrated to the new profile?

• Mail

• Contacts

• Calendars

• Notes

• Tasks

• Default Categories
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What information will not be migrated to the new profile?

Please note that local Outlook profile settings and customizations may not be copied over and if you 
want to keep any of these settings you must follow the instructions outlined below. 

Rules

Rules will not be migrated -– If you would like to migrate your rules, please follow the instructions 
below BEFORE your scheduled cutover.

Export Rules in Outlook

Outlook 2003/2007: Choose Tools > Rules and Alerts, then click Options. In the Options window, click 
Export Rules, and choose a file location. 

Outlook 2010/2013: On the File tab on the Ribbon, click Info > Manage Rules and Alerts, then click 
Options. In the Options window, click Export Rules, and choose a file location. 

Once your profile is converted to the new Exchange profile import the rules into the new profile 
(Reverse the process to IMPORT your saved rules)

OUTLOOK > RULES > MANAGE RULES & ALERTS

Diagnostic Information

Outlook rules are stored in .rwz files with the name of your profile in the default Outlook directory.

To open the default folder for Outlook files, go to Start > Run and insert the path below for your 
operating system:

XP: %USERPROFILE%\Application Data\Microsoft\Outlook 

VISTA, Windows 7: %USERPROFILE%\AppData\Roaming\Microsoft\Outlook

Note: 

FOLDERS IN RULES MAY NEED TO BE MANUALLY REAPPLIED - Always check all the imported 
rules to make sure they’re still active. Sometimes they’ll be blank (especially in the case of rules 
for moving or copying to a folder) because Outlook can’t be sure that the destination folder is the 
same as in your original rule.
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Categories

Categories with custom names or non-default Category Colors will not be migrated -– Only default 
category colors with default names are migrated. Colors that are associated with custom categories 
cannot be migrated at this time and users will need to reassign colors to these custom categories. 
For help resetting the names please see the FAQ at the end of this document.

Local Folders (Archive)

Local mail folders are any folders not stored on the server. If you are unsure if you have any contact 
your local administrator. To add a local archive folder follow the instructions below:

Outlook 2013: File > Open & Export > Open Outlook Data File > Browse to .pst > Open

Outlook 2010: File > Open > Open Outlook Data File > Browse to .pst > Open

Outlook 2007: File > Open > Open Data File

Follow these steps to see where Outlook is currently storing your data:

In Outlook 2010/2013:

1. Click the File tab on the Outlook ribbon.

2. In the Info category, click the Account Settings button, and then click Account Settings.

3. In the Account Settings window, click the Data Files tab.

In Outlook 2007:

4. On the Tools menu, click Options, click the Mail Setup tab, and then click E-mail Accounts.

5. In the Account Settings window, click the Data Files tab. 

• Personal and External Email Accounts

Personal email accounts – These include GMAIL, YAHOO, and HOTMAIL etc.  These will need to be 
re-associated with the new profile. Contact your personal email provider for instructions on adding 
the external account.

white pAper:

A Systematic Approach for Large-Scale Migrations  



17

Email 2: Conversion Date Procedures
Follow the instructions below on the date and time of the conversion. 

EMAIL CONVERSION [MONTH, DAY OF MONTH, 2013 @ TIME + TIME ZONE]

Steps for Creating New Outlook Profile

1. Download Outlook Profile Helper

Navigate to owa.serverdata.net. CLICK on “My Services”, type your $USERNAME email address and 
password.

Once you are logged in, CLICK on “Downloads and Instructions” to take yourself to the download 
page.

Under Single Sign On, CLICK on the Outlook Profile Helper Link at the bottom

Once the tool is downloaded, run the tool and continue to the next step.
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2. Create new exchange profile

Enter your primary mailbox address and $USERNAME password and select NEXT. Follow the 
prompts as shown in the screen shots below to setup the new Outlook profile.

3. Prepare Outlook for first use

You will be prompted to Open Outlook for the first time. This will begin the e-mail download. You 
should see the status Updating this folder in the bottom right of Outlook.

You should not use Outlook while Outlook downloads your e-mail; instead use OWA (login as a user to 
owa.serverdata.net with your primary mailbox address and password).

Not accepting username or password?

Try logging in as a user into webmail (OWA) at owa.serverdata.net. If you are not able to login 
to the OWA with your primary mailbox address and password, reset your computer’s password 
from your local workstation, wait 15 minutes and try the new password in the OWA again. If the 
problem persists, contact your local administrator for assistance with a password reset.
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4. Using webmail (OWA) while Outlook builds the new profile

Login as a user to owa.serverdata.net

You should use OWA until Outlook is finished downloading its local copy and the Outlook status at the 
bottom shows – ALL FOLDERS ARE UP TO DATE.

If you continue to experience issues with your Outlook profile conversion:

Please contact your local Administrator with any questions or issues.
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