, , ,

What Intermedia customers need to know about the POODLE/SSLv3 vulnerability

Some of you may have heard about POODLE/SSLv3, a major security bug that’s been making headlines this morning.

For those of you who have not yet seen the news…researchers recently discovered a security bug in the widely used web encryption protocol SSL (secure sockets layer). This technology is what prevents someone sitting next to you in a coffee shop from watching your transactions as you access your online bank account or intercepting your username and password as you log in to your email or other web services.

This vulnerability allows the plain text of secure connections to be calculated by a network hacker, which can be used to obtain critical authentication information to things like email, bank accounts and other highly sensitive services.

How does it affect Intermedia’s services?

Security is a top priority for us. To ensure that this bug does not impact our customers, we are actively disabling SSLv3 across all our services, for all products. We’re working to complete this as quickly as possible. During this period, customers will still be able to utilize our services using TLS (transport layer security), a stronger standard of encryption.

What can you do to help ensure you’re protected?

While we are working diligently to ensure your services are protected, the true solution to this vulnerability is to disable SSLv3 at the client level. Take a look at our KB article for instructions on how to disable SSLv3 on your browser.

Our support team is happy to answer any questions you may have about this vulnerability. Feel free to contact Intermedia support at any time for assistance.

 

About Ryan Barrett

Ryan is Intermedia’s Vice President for Security and Privacy.